Message Center
Updated July 7, 2026: We have updated the timeline. Thank you for your patience.
Introduction
To improve endpoint performance and focus on higher-value network telemetry, Microsoft is removing SMB signature inspection events from Advanced Hunting in Microsoft Defender for Endpoint. This change reflects observed low customer value for SMB signature data on endpoints and our continued investment in more advanced SMB visibility through Zeek-based network capabilities.
When this will happen:
The rollout to Worldwide, GCC, GCC High, and DoD will begin on July 1,13, 2026, and will complete shortly thereafter across all tenants.
How this affects your organization:
Who is affected:
What will happen:
ActionType = “NetworkSignatureInspected” and SignatureName = “SMB_Client” will no longer be generated.What you can do to prepare:
To continue identifying SMB traffic in Advanced Hunting, we recommend filtering on port 445, the standard port used by SMB, in the DeviceNetworkEvents table, which remains fully supported.
SMB_Client.Query update example
Replace:
DeviceNetworkEvents
| where ActionType == "NetworkSignatureInspected"
| extend SignatureName = tostring(parse_json(AdditionalFields).SignatureName)
| where SignatureName == "SMB_Client"
With:
DeviceNetworkEvents
| where RemotePort == 445 or LocalPort == 445
For questions or feedback regarding this change, contact Microsoft Support or your Microsoft account representative.
Compliance considerations:
Introduction
To improve endpoint performance and focus on higher-value network telemetry, Microsoft is removing SMB signature inspection events from Advanced Hunting in Microsoft Defender for Endpoint. This change reflects observed low customer value for SMB signature data on endpoints and our continued investment in more advanced SMB visibility through Zeek-based network capabilities.
When this will happen:
The rollout to Worldwide, GCC, GCC High, and DoD will begin on July 1, 2026, and will complete shortly thereafter across all tenants.
How this affects your organization:
Who is affected:
What will happen:
ActionType = “NetworkSignatureInspected” and SignatureName = “SMB_Client” will no longer be generated.What you can do to prepare:
To continue identifying SMB traffic in Advanced Hunting, we recommend filtering on port 445, the standard port used by SMB, in the DeviceNetworkEvents table, which remains fully supported.
SMB_Client.Query update example
Replace:
DeviceNetworkEvents
| where ActionType == "NetworkSignatureInspected"
| extend SignatureName = tostring(parse_json(AdditionalFields).SignatureName)
| where SignatureName == "SMB_Client"
With:
DeviceNetworkEvents
| where RemotePort == 445 or LocalPort == 445
For questions or feedback regarding this change, contact Microsoft Support or your Microsoft account representative.
Compliance considerations: